Loading...

Immediate Oxidation of paint

Welcome Forums Main Forum Introductions Immediate Oxidation of paint

This topic contains 0 replies, has 1 voice, and was last updated by Profile photo of Rahul Jones Rahul Jones 2 years, 2 months ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #48599
    Profile photo of Rahul Jones
    Rahul Jones
    Participant

    Hi guys,

    I am new to this forum and here is my issue. My car is a 1996 Alfa Romeo 155 which is Rosso red in color at least thats what it is supposed to be. But my car had a cheap complete car paint job at some point of its life before I got the car. I am calling it cheap because of the uneven spray pattern and what looks like high humid condition during the paint job.

    I tried polishing my car twice but the paint soon gets oxidized. I do live in a very hot region that could be one reason but I waxed it immediately after the polishing but soon after the first wash it starts to fade.

    During the polishing process I used Meguairs Ultimate Polishing compound and Meguairs Ultimate Paste Wax in the end. This process was done with a foam pad the first time and with a wool pad the second time. I used a drill attachment to buff the car with an RPM of less than 850.

    I don’t think I can anymore buff the car as I see small dot of primer here and there. Was there anything wrong with my procedures? Or was the clear coat of bad quality? If so, respray could be the option?

    NOTE: I will post pics tomorrow morning as I can get the pic to prove my point.

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.